summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorMaxwell Beck <max@rastertail.net>2025-03-30 15:46:30 -0500
committerMaxwell Beck <max@rastertail.net>2025-03-30 15:46:30 -0500
commit1d888631c3e4c423c2b782b01ca29fc1057c51a2 (patch)
treec43e996ea16b577ee7a02b5d4f97ecf99dde033c /flake.nix
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..f425c9b
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,25 @@
+{
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
+    fenix = {
+      url = "github:nix-community/fenix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+  };
+
+  outputs = { self, nixpkgs, fenix }:
+    let
+      system = "aarch64-darwin";
+      pkgs = nixpkgs.legacyPackages.${system};
+      fpkgs = fenix.packages.${system};
+      rust = with fpkgs; combine (with stable; [
+        defaultToolchain
+        rust-analyzer
+        rust-src
+      ]);
+    in rec {
+      devShells.${system}.default = pkgs.mkShell {
+        packages = [ rust ];
+      };
+    };
+}