summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxwell Beck <max@rastertail.net>2024-12-28 19:09:06 -0600
committerMaxwell Beck <max@rastertail.net>2024-12-28 19:09:06 -0600
commitbc3fbeb48dea39d7213fb257a56e35bcacba9e8d (patch)
tree9b0f0bbad177e4f73c8a6074e79b5a8f0332b63a /CMakeLists.txt
parentdbe367d5a302300e598187eaf4c369eb06f5ec48 (diff)
Use multicore to meet timing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59c6d70..0f4a923 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ include(pico_sdk_import.cmake)
 project(pico1541 VERSION 0.1.0)
 pico_sdk_init()
 
-add_executable(pico1541 src/pico1541.c src/6502.c src/6522.c src/drive.c testbin/1541.o testbin/testimage.o)
+add_executable(pico1541 src/pico1541.c src/6502.c src/6522.c src/drive.c testbin/1541.o testbin/bsk1.o)
 pico_set_binary_type(pico1541 copy_to_ram)
-target_link_libraries(pico1541 pico_runtime hardware_timer)
+target_link_libraries(pico1541 pico_runtime pico_multicore hardware_timer)
 pico_add_extra_outputs(pico1541)
\ No newline at end of file