summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..59c6d70
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.13...3.27)
+
+include(pico_sdk_import.cmake)
+
+project(pico1541 VERSION 0.1.0)
+pico_sdk_init()
+
+add_executable(pico1541 src/pico1541.c src/6502.c src/6522.c src/drive.c testbin/1541.o testbin/testimage.o)
+pico_set_binary_type(pico1541 copy_to_ram)
+target_link_libraries(pico1541 pico_runtime hardware_timer)
+pico_add_extra_outputs(pico1541)
\ No newline at end of file